Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#7 closed task (fixed)

Regression test framework

Reported by: andy Owned by: marius
Priority: major Milestone: 0.2
Component: Renderer Version:
Keywords: Cc:

Description

We should add automatic verifying regression tests.

We may use a directory for testdata (rules and *.osm files) and one for expected output. The testrunner renders each data file into a png image and then compares with previously generated png images for differences.

Change History (2)

comment:1 Changed 6 years ago by andy

We can use the ImageMagick? tools to compare the expected output with the current output.
The identify tool compares a signature which can easily compared to expected output:

compare expected/16.png tiles/16.png miff: | identify -verbose - | fgrep -i signature

comment:2 Changed 6 years ago by andy

  • Resolution set to fixed
  • Status changed from new to closed

This is working since [66]. See TestCaseRunner for details.

Note: See TracTickets for help on using tickets.