Opened 4 years ago

Closed 4 years ago

#26 closed defect (fixed)

Should be linked against libmath (-lm)

Reported by: Laurent Bigonville <bigon@…> Owned by: marius
Priority: major Milestone: 0.2
Component: Core Version:
Keywords: Cc:

Description

It looks like libmemphis should be linked against libmath too

dpkg-shlibdeps: warning: symbol hypot used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol sinh used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol floor used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol log used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol atan used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol ceil used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol exp2 used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol tan used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol cos used by debian/libmemphis-0.2-0/usr/lib/libmemphis-0.2.so.0.0.2 found in none of the libraries.

Change History (2)

comment:1 Changed 4 years ago by simon

Thanks for trying to package memphis.

I can't reproduce your bug, but I added an explicit "-lm" in rev 208. I hope this solves it.

comment:2 Changed 4 years ago by simon

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.